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Excel training - Advanced 
Average sum 

1. Open the Excel training – Advanced workbook 

2. Select the sheet 12. Average, Min & Max 

3. Select cell F3 

4. Select the Formulas > Function library > AutoSum drop down menu and select Average 

 
5. Press Enter, the formulas should automatically add down as we are working in a table 

’ 

 

Minimum and Maximum 
1. Select cell G2 

2. Create the heading Maximum, and select Enter or Tab 

3. Select cell H2 

4. Create the heading Minimum, and select Enter or Tab 

5. Select cell G3 

6. Type in the formula =MAX(B3:E3) 

7. Select cell H3 

8. Type in the formula =MIN(B3:E3) 
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Date and Time 
1. Open 13. Date and Time worksheet 

2. In cell B2 type in the formula =today() 

3. Press Enter 

4. In cell B3 type in the formula = NOW() 

5. Right mouse click on cell B3, select Formal Cells, under the Number tab, select Custom 

and then type the format hh:mm AM/PM in the Type box 

6. Click OK 

 

 

 
 

  



4 
 

How to merge two tables in Excel with formulas 
Join tables using VLOOKUP 
If you are wanting to join two tables together based on one column, then VLOOKUP is a very easy 
formula to use.  We have 2 tables, one called 14. Merge Main and the second one is 14. Merge 
lookup.  The first table contains the seller name and product and the lookup table contains the 
names and amounts.  You want to combine these two tables by matching data from the seller 
column.  The order of the names in both columns is different, so that is why a copy and paste won’t 
work.  
The formula we are using is the VLOOKUP 
 
=VLOOKUP(lookup_value, table_array, col_index_number, [range_lookup]) 
 

 

 

 

1. Select the sheet 14. Merge Main 

2. To combine the two tables by a matching column (seller), you enter this formula in cell C2 in 

the main table 

 

Type in the formula =VLOOKUP($A2, '14. Merge lookup'!$A$2:$B$8, 2, FALSE) 

 

 

• lookup_value - $A2 is the value you are looking for 

Notice that there is a $ sign before the A. This means absolute cell reference  

Excel's default formula notation uses relative cell references. Relative references 

automatically change when you copy cells with the clipboard or fill handle, 

making it easier to reuse formulas. In cases where you need Excel to keep the 

exact cell referenced in a formula, switch the formula to use absolute references 

by pressing "F4" to add a dollar sign to the equation. 

 

• table_array  - '14. Merge lookup'!$A$2:$B$8 – is the table to search.  We have 

named the table as lookupSeller, so this formula could be replaced as 

 

=VLOOKUP($A2, LookupSeller, 2, FALSE) - where we are just referencing the 

table name 
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• col_index_number - 2 is the number of the column from which to retrieve the 

value. 

• [range_lookup] - Optionally, you can specify TRUE if you want an approximate 

match or FALSE if you want an exact match of the return value. If you don't 

specify anything, the default value will always be TRUE or approximate match. 

Please be aware that Excel VLOOKUP has several limitations, the most critical of which are 1) 

inability to pull data from a column to the left of the lookup column and 2) a hardcoded 

column number breaks a formula when you add or remove columns in the lookup table.  

Convert VLOOKUP values to absolute cell reference 
Once you have merged your data you can now change the formula to be just the values.  This will 

mean that the data is not relying on the second table. 

1. Select cells C2 to C8 

2. Press Ctrl + C to copy 

3. The right click and select Paste Options, click values 

 

4. Go to cell C2 and notice that the cell is just a value and not a formula 

 

How to merge two tables in Excel with Power Query 
We are going to use the same data, but this time use the Power Query. Power Query can save you a 
lot of time when you need to merge tables with different sizes and columns based on a matching 
column. 
 

1.  Delete Column C in Table 1 
 

TABLE 1 – MAIN TABLE          TABLE 2 – AMOUNT TABLE  
 

 
 
 
 
 
 
 
 
 
 

 

2. Select the table 1 – Main Table, but clicking in any cell 
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3. To merge tables, you first need to convert these tables into connections in Power 
Query. Once you have the connections, you can easily merge these. Select the Data 
Tab > From Other Sources > From Table/Range 

 

 
 
 

4. This will open the Power Query editor, showing your table 

 
5. In the Query editor, click the File Tab, then Close and Load To option 

 
6. In the Import Data window, select Only Create Connection. 

 
7. Click OK. 
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8. The data has created a connect that is now displayed on the right hand side of the 
screen. 

 
 

9. Select the 14. Merge Lookup worksheet 
10. Select the Amount Table 
11. Select Get Data > From Other Source > From Table Range 
12. Select File > Close and Load To 
13. In the Import Data window, select Only Create Connection  
14. To connect the tables together, select the Data tab, then Get & Transform Data 

group, then Get Data > Combine Queries and Merge. 
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15. In the Merge table window select the Main Table in the first drop down box 
16. Select the Seller column on the Main Table 
17.  column on the Main table 
18. Then in the second table select the Amount Table 
19. Select the Seller column on the Amount Table 
20. Under Join kind, select Left Outer ( all from first, matching from second) 

 
21. Select OK 
22. In the Power Query editor select the icon to the right of the Amount Table column 
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23. Uncheck the Seller column, then select OK 

 
24. Now select Close and Load 

 
25. This has created a new worksheet with your data merged.  Rename the spreadsheet to 

Merge Data 
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Excel Dashboards – Case study 3 C sales 
Benefits 
 
An Excel dashboard is a one page summary that contains important information which allows you to 
analyse your business.  
 

About 3 C Sales 

• The 3 C sales is a sales company that sells cookies, chocolates and cereals in Australia 

• The 3 C sales has 6 sales reps 

What are the goals of our dashboard? 
The goal of a dashboard is to maximize the performance of a business.  The dashboard can 

communicate key business information to colleagues and stakeholders.  Such as highest sales per 

State, per sales rep or per product. 

The pivot tables that we will create for our 3 C sales dashboard are: 

• Sales per category 

• Sales per Sales rep 

• Sales per state 

• Sales per product 

This data shows the date of the sale, the country and state, the sales rep, the category of product 
and product, the quantity of sales, unit price and total price. 
 

Sales per category pivot table 
 

1. Open 15. Data sheet 

2. Select any cell in the Data table 

3. Select Insert > Tables > Pivot Table 

 

4. In the Create PivotTable window, the Select a table or range will have automatically 

selected our Data table.  In the Choose where you want the PivotTable report to be placed, 

we are keeping the default New Worksheet. 
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5. Click OK 

6. Right mouse click on the new sheet and select Rename 

7. Type in Sales by category 

8. The PivotTable Fields pane appears, drag the following fields to the different areas 

o OrderDate to the Rows area – If you are using Excel 2016 it will automatically group 

the dates.  If you don’t want the dates to be grouped you could select Ungroup from 

the Analyse tab (or select Ctrl Z).  If you don’t have Excel 2016, you can group 

manually by right clicking on any date and then select Group, then group by Months 

and years.  We are going to leave it grouped. 

o Category to Columns area 

o TotalPrice to Values area 

 
 

9. Select cells A5 and A6, right mouse click and select Group 
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10. Make sure that Months, Quarters and Years are selected as the grouping option.  

 

 

11. Click OK 

12. Now give the PivotTable a name- CategoryPivot 

13. Select cell E5, right mouse click, and select Number Format 

14. In the Format Cells area select Currency and then 0 decimal places 

 

15. Select OK 

16. Select Insert > Charts > PivotChart drop down menu > Pivot Chart  

17. From the Insert Chart window, select Line then click OK 

 

18. Drag the line graph to the right of your data 

19. Right mouse click on the heading for Sum of TotalPrice and select Hide all field buttons on 

chart 
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20. Move the legend to the top right hand corner of the chart 

21. Resize the graph to display all months 

22. Create a new sheet on your workbook by selecting the plus sign 

23. Rename new worksheet Dashboard 

24. Drag the Dashboard sheet to just after 14.Merge lookup sheet  

25. Resize the columns in the Dashboard to the following 

• column A  and column L to - size 2  

• column B to column K - size 9  

• column M and Column N – size 13  

• column O through to column U - size 9 

26. Change Row 1 to height 45 

27. Go back to your sales by category worksheet and click on the line graph (making sure only 

the outside borders are selected 

28. Select Format > Size > Change the height to 6cm and width to 12cm 

 
29. Hold down the Ctrl button + X (Which will cut the graph) 

30. Now go over to the Dashboard sheet and press Ctrl + V to paste 

31. Drag the graph to the top of cell M14. To get it to snap to grid, hold down the Alt key while 

moving the graph with you mouse 

Sales by Rep Pivot Table 
1. To ensure that all of the pivot tables share the same source data, we are going to copy from 

the Sales by Category sheet. 

2. Select the Sales by Category worksheet 

3. Hold down the Ctrl key, left click on the Sales by Category sheet and drag the sheet over to 

the next tab. A plus sign will appear 

4. Rename the sheet Sales by rep 

5. Rename the table to be repPivot 

6. In the PivotTable Fields drag the following fields to the different areas 

a. Category to the Columns area  

b. Sales Rep to Rows area 



14 
 

c. TotalPrice to Values area 

 

 

 

7. Now add a pivotable graph (column) as below, this time removing the legend 

 
8. Select Format > Size > Change the height to 6cm and width to 12cm 

9. Cut the graph using Ctrl X  

10. Select cell E3 on the dashboard worksheet, then past the chart at the top of this cell 

Total sales Pie Chart 
1. Copy sheet Sales by rep 

2. Rename the new sheet pie Chart 

3. Rename the table to be PiePivot 

4. In the PivotChart Fields, drag the following fields to the different areas 

d. Category to the Rows area  

e. TotalPrice to Values area 

$0

$1,000

$2,000

$3,000

$4,000

$5,000

$6,000

$7,000

$8,000

Jessica John Richard Sally Samuel Wendy
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5. Create a Pie PivotChart 

6. Add Data Labels, remove the Title, Legend and Sum of Totals 

7. Select Format > Size > Change the height to 5cm and width to 5cm 

8. Remove the dollar sign from the data 

9. Change the size of the Data Labels to 8 

10. Copy the Pie Chart to the dashboard in cell R3 
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Sales by State 
1. Copy sheet Pie chart 

2. Rename the new sheet Sales by State 

3. Rename the table StatePivot 

4. In the PivotChart Fields drag the following fields to the different areas 

o Country, then State to the Rows area  

o TotalPrice to Values area 

5. Right mouse click on the Australia under Row labels, select Field Settings, then Layout and 

Print tab, then click Show item labels in tabular form and check the tickbox for Repeat item 

labels 

 
6. Click OK 

7. This time you are going to create a Map Chart.  However, this can’t be in a pivot format.  

Select the full table (highlight all cells), right click and select copy  

 

8. Move to cell E3, right mouse click and select Paste Options, then select values 
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9. Now select from cell E3 to G9, then select Insert and then Maps 

10. Right mouse click on the chart displaying a picture of Australia 

11. Select the Select Data 

12. Change the data source to ='Sales by State'!$A$3:$C$9 (or you can select all cells from A3 to 

C9 manually yourself) 

 
13. Click OK 

14. Delete the copied data in cell E3 to G9 

15. On the Australia chart add data labels, 

16. Select Chart Design > Chart Styles >Change Colors, use the drop down menu to change the 

color of the chart to be black and white

 
17. Remove the legend and the chart title 

18. Change the size of the chart to the 5cm by 5cm 

19. Copy the Australian graph to the Dashboard, place in cell N3 
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Adding Slicers to the Dashboard 
1. Select the Dashboard sheet 

2. Select the line Chart, then select Insert and Slicer 

3. Add the slicers – Category, Years and sales rep, select OK 

4. Right mouse click on the slicer Years and change Slicer Settings to hide items with no data  

5. Right mouse click on the slicer Category and select Report Connections 

 

 

 

6. In the report Connections, select the CategoryPivot and the SalesPivot.  Do this for all slicers 

 

This will allow us to use the same slicer buttons for the Category and the sales graphs. 

 

Formatting the Dashboard 
1. Highlight cells A1 to U1, select Home > Alignment > Merge and Center 

2. Right mouse click, then select Format Cells, then select Fill tab, then select a dark grey color 

3. Type the heading in row 1 – 3 C Sales Dashboard 

4. Change the font to Berlin Sans FB Demi, size 36 

5. Move all slicers over to the left hand side of the dashboard  

6. Change the size for the slicer buttons to the following 
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Years  

 
move to cell B5 

 

Category 

 
Move to cell B11 

 

Sales Rep 

 
Move to cell B18 

 

Creating a legend for the dashboard header 
1. Select Insert > Illustrations > Shapes > Rectangle 

 
2. Create a rectangle 3cm by 0.8cm, color blue (Shape Format > Size), place this shape on the 

heading bar at the top left of the worksheet 

3. Right mouse click on the shape and select edit text, type in Cereal, align the text center 

(Home > Alignment > Center) 

4. Copy and paste this shape, making the name being Chocolates and colour Orange 

5. Copy and paste another shape calling this Cookies and the colour light Grey 
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6. These 3 shapes will become the new legend for your dashboard, you will be able to delete 

the legend on the line chart 

 

 

 

 

 

 

  

 

 
 
 
 
TIPS and TRICKS 

 
Snap to Grid - When you draw, resize, or move a shape or other object in 
Excel, you can set it so that it will align or "snap” to the nearest intersection 
in the grid (even if the grid is not visible) or snap to other shapes or objects. 
However, you can control the alignment and snap-to capabilities by turning it 
off. 
 

Shape Format > Arrange > Align > Snap to Grid 
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Insert pictures 
1. Select Insert > Illustrations > Pictures 

2. Find the location of the 3PSales images 

3. Place on the right hand side of the header 

 

Fixing errors in graphs on the dashboard 
1. From the sales rep slicer display only sales from Jessica 

2. Notice that the line chart is not displaying data as a zero value, so we need to fix this 

3. Select the line chart, then right mouse click and select Pivot Chart Options 

 
4. On the Layout & Format, uncheck the tickbox – For error values show and For empty cells 

show 

 

5. Click OK 

6. Remove the legend from the chart as we now have this on the toolbar 
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Clear slicers 
To clear any filters applied, click the “Clear Filters” button in the upper-right corner of 
the slicer pane. To delete a slicer, select the slicer pane and then press the “Del” or “Delete” key on 
your keyboard. We are going to create a clear slicer button using a Macro 
 

1. The Developer tab isn't displayed by default, but you can add it to the ribbon. File 

> Options > Customize Ribbon. 

2. Under Customize the Ribbon and under Main Tabs, select the Developer check box. 

After you show the tab, the Developer tab stays visible, unless you clear the check box or 

have to reinstall a Microsoft Office program. 

3. Select 2018 from the Year Slicer 

4. Select Cereal from the Category slicer 

5. Select Jessica from the Sales Rep slicer 

6. From the Developer tab, select Record Macro, in the Code group 

7. Name the Macro – ClearSlicers 

 
 

8. Select OK 

9. Select the Clear Filter from all 3 slicers 

 

10. From the Developer tab, select Stop Recording from the Code group 
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10. Select cell B3, select Developer > Controls > Insert > Form Controls > then select the Button 

 
11. Make a button in cell B3 around 4.8cm in width and 0.8cm in height (user the Shape Format 

tab)  to be the same as your slicer blocks. 

12. In the Assign Macro window, select ClearFilters and press OK 

 
13. Right mouse click on the button and select Edit Text 

14. Rename the button – Clear Slicers 

15. Test your button by selecting various slicers and then using the Clear Slicers 
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Making our Legend buttons interactive 
1. Select Developer > Code > Record Macro 

2. Name the Macro Cereal, then click OK 

3. On the Slicer Category, select the Cereal button 

4. Select Developer > Code > Stop Recording 

5. Right mouse click on the Cereal button and select Assign Macro 

 

6. Select the Cereal Macro and press OK 

 
7. Do the same steps for the Chocolate and Cookies button, however this time also add change 

the color on the graphs when recording the macro. You can do this by right clicking on the 

graph and then using the drop down Fill menu to select the color that is the same as the 

legend. 
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Adding a Timeline 
1. Select the Sales column graph 
2. Select PivotChart Analyze > Filter > Insert Timeline 
3. Click Order date, then select OK 

 

 
 

4. Drag down to cell E15 
5. Select Timeline > Size and change height and width 
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TOTAL CATEGORY USING THE FORMULA SUMIFS 
1. In cell M4 type in Start date 
2. In cell M5 type in End date 
3. In cell N4 type in the data 01/10/18  
4. In cell N5 type in the formula =today() 
5. Highlight cells M4 to N5 
6. Select Home > Font > Borders > All Borders 

 
7. In cell M6 type in Cereal 
8. In cell M7 type in Chocolates 
9. In cell M8 type in Cookies 
10. In cell M10 type in Total 
11. In cell N6 type in type in the formula 
12. =SUMIFS(Data[TotalPrice], Data[Category], "cereal", Data[OrderDate], ">="&N4, 

Data[OrderDate], "<="&N5) 
13. In cell N7 type in the formula 
14. =SUMIFS(Data[TotalPrice], Data[Category], "Chocolates", Data[OrderDate], ">="&N4, 

Data[OrderDate], "<="&N5) 
15. In cell N8 type in the formula 
16. =SUMIFS(Data[TotalPrice], Data[Category], "Cookies", Data[OrderDate], ">="&N4, 

Data[OrderDate], "<="&N5) 
17. Highlight from cells N6 to N10 and use the SUM to create a total 

 

 

SYNTAX FOR SUM IFS 
=SUMIFS (sum_range, range1, criteria1, [range2], [criteria2], ...) 
Arguments 
Sum range - The range to be summed. 

range1 - The first range to evaluated. 

criteria1 - The criteria to use on range1. 

range2 - [optional] The second range to evaluate. 

criteria2 - [optional] The criteria to use on range2. 

 

 
Excel's SUMIFS function sums cells in a range using supplied criteria. Unlike the SUMIF function, 
SUMIFS can apply more than one set of criteria, with more than one range 
 
Note that we need to enclose the logical operators in double quotes ("") then join with cell 
references using an ampersand (&). 
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Hyperlink buttons 
1. In cell E24 create a rectangle shape that will be used as a hyperlink button 

2. Create the size 0.8cm x 5.7cm 

3. Right mouse click to Edit the name to be Sales by Category 

4. Right mouse click to add a Link 

 
5. Link to – Place in This Document and select Sales by category 

6. Select OK’ 

7. Copy this button and create another one in cell I24 

8. Call this one Sales by Rep and link to the corresponding worksheet 

9. Save your document 

10. Adjust your page in any way that will make it look better 

 

 


