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Data & Dashboards - Intermediate 
 

Intermediate Excel will take you to the next level in Excel. 

Refresh - Microsoft Ribbon 
The best way to understand Excel is to get an understanding of the Microsoft Ribbon and the tabs.  

All functions and commands are located in the Ribbon that stretches across the top of the screen 

 

Microsoft Excel opens with the Home tab selected. The Home tab is used for entering, editing and 

formatting data 

 

 

 

 

 

 

 

 

 

 

 

 

The Ribbon contains multiple tabs, each of which contain certain operations.  Other tabs include;  

1. Insert Tab – Contains controls for adding various items into the spreadsheet 

2. Page Layout Tab – controls the look and feel of the spreadsheet 

3. Formulas Tab – Creating and editing formulas 

4. Data Tab – tools for analysing the data in the spreadsheet 

5. Review Tab – Allows managing spreadsheet changes 

6. View Tab – Enables you to change how you view the spreadsheet 

 

Group 

Dialog box 

launcher 

Tab 

Drop 

down 

menu 
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Mininize the Ribbon 
 

The ribbon can be minimized so that only the tabs are shown. When minimized, you can click the tab 

to temporarily view the tab’s controls 

1. Minimize the ribbon area by clicking the arrow in the lower-right corner of the ribbon 

 
2. Open the ribbon back up by clicking any tab 

3. Lock the ribbon open by clicking the pin that now appears where the arrow used to be      

 

Hyperlinking with Excel 
Excel allows you to hyperlink to Web Pages or reference in your document 
 

1. Open the Excel training workbook – Intermediate  
2. Select the Start tab 
3. Right mouse click on the Next button 
4. Select the Link button  
5. Select Place in This document 

6. In the Cell Reference, select 6. Sorting 

 

7. Select OK 

8. Click in any cell, so the Next button is not selected 

9. Now left click on the left arrow, it will take you to the 6.Sorting sheet 
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Sorting Data 
There are many ways to sort data in Excel. 

Filter data  
1. From the Country drop down menu, select Sort A to Z. Note this data is located in a 

table, so it automatically has a drop down menu.  To turn off the filter select Data>Sort 

& Filter>Filter 

 

2. Select Ok 

 

3. From the Department drop down menu, unselect Select All  

4. Check the tickbox for Clothing 

 
5. Select OK 

 
 

6. Select Data > Sort & Filter > Clear 
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Sort data by 3 columns 
Follow these steps to safely sort by the 3 columns: 

1. Select any cell in the table 
2. Select Data > Sort & Filter > Sort 

 

 
 
 

3. Select the drop down menu on Sort by to select Country 
4. Select Add Level 
5. Select Department on the Then by drop down menu 
6. Select OK 

 

 
 

Sort by colour 
You can sort data based on the color.   

1. Right click on row 10 and select Format Cells 

2. In the Format Cells window, select the fill tab and then the color yellow, click OK 

3. Right click on row 12 and select Format Cells 

4. In the Format Cells window, select the fill tab and then the color green, click OK 

5. Select anywhere in the table 

6. Select Data > Sort & Filter > Sort 

7. Under Column, select Sort by Country and Sort 

On cell color.   

8. Use the drop down menu on Order and select the 

green color 

9. Do the same for Then by, this time the Order will 

be yellow 

 

10. Click OK 
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As you can see, Excel has ordered all of the cells by color, with the green on top, the yellow next and 

the cells with no color is under this. 

Task:  Try sorting by no cell colour first, then yellow, then green 

Conditional formatting 
It would be extremely difficult to see a pattern or trend in your data if you have thousands of rows 
or columns of data.  This is where conditional formatting provides another way to visualize data and 
make worksheets easier to understand and read. 
Conditional formatting allows you to automatically apply formatting such as colors, icons and data to 
one or more cells.  
 

1. Select the cells D3 to F12 
2. Select Home > Style > Conditional Formatting drop down menu > Highlight Cell Rules > 

Greater Than 
3. Type in 100 in the Format cells that are GREATER THAN. 
4. In the with select the drop down menu to select Custom Format 

 

 
 

5. In the Format Cells window, select the Fill tab, then select the blue color and then OK 
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Traffic lights  
Based on a range of values you can show the Red, Yellow or Green indicators. 

1. Select the cells D3 to F12 
2. Select Home > Style > Conditional Formatting drop down menu > Icon Sets > Shapes > 

Select 3 traffic lights (Rimmed) 

 
 

3. Select Home > Style > Conditional Formatting > Manage Rules 

 
4. Select Icon Set, then Edit Rule, change the following rules to be 

Green – When value is > = 100 Number 

Yellow – When value is >= 50 Number 

Red – When value <= 50 

 
5. Click OK, then OK again 

 

 
 
 
TIPS and TRICKS 

 
 To remove conditional formatting rules: 
Select the cells that have conditional formatting. 
In the Home tab, click the Conditional Formatting command. A drop-down 
menu will appear. Select Clear Rules. 
 
A menu will appear. You can choose to clear rules from the Selected Cells, 
Entire Sheet, This Table, or This PivotTable. 
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Data Bars 
Data Bars show the differences among the amounts.  A full data bar will represent the highest figure 
and the rest will be based on a proportion of this amount. 
 
There are two sets of Data Bar options -- Gradient Fill and Solid Fill. 
Solid Fill is a better choice if the data bars if the numbers will be hidden in the cells  
Gradient Fill is better if the numbers will be visible in the cells -- the lighter colours at the end of the 
gradient make it easier to read the numbers. 

 

Data Bars – Gradient Fill 
1. Select cell G2, type in the heading – Total 

2. Select Enter 

3. Select cell G3, type in the formula =SUM(D3:F3) 

4. Select Enter 

5. Highlight cells G3 to G12 

6. From the Home Tab select Styles group, then Conditional Formatting drop down menu, 

then select Data Bars and Gradient Fill 

 

 
7. Select the blue gradient fill 
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8. Make column G a width of 20. This will make it easier to see the difference among the bars. 

In a wider column, the numbers at the right will be positioned over the lighter part of a bar 

with the gradient fill. 

 

9. Make all cells from G3 to G12 bold 

  

 

Data Bars – Solid Fill 
After you add Data Bars, you can change the conditional formatting settings, so only the data bars 
are shown in the cell, without the numbers. 

1. Select cells D3 to D12 
2. Select Home > Styles Group > Conditional Formatting > Manage Rules 
3. Double click on the Data Bar rule. Or select Edit rule 

 

 
 

4. In the Edit Formatting Rule window under “Edit the Rule Description” add a check mark to 
Show Bar Only and under Bar Appearance use the drop down menu under Fill to select 
Solid Fill 

 

5. Select OK, then OK again 

 
6. Change the value of cell F12 to 3000, to nice the change in the data bars 
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Set Data Bar Minimum 
When you add Data Bars, their minimum and maximum values are automatically set, usually with a 
minimum of zero, and a maximum that matches your highest value. 

1. Select D3 to D12  
2. Select Home > Styles group > Conditional Formatting > Manage Rules. 
3. In the list of rules, click your Data Bar rule, then click the Edit Rule button 
4. In the "Edit the Rule Description", change the Minimum to type number and Value to 19.99 

and the Maximum to Number and Value of 5000 

 
 

SUMPRODUCT –one criteria with multiple columns 
SUMPRODUCT is a function in Excel that multiplies range of cells or arrays and returns the sum of 
products. It first multiplies then adds the values of the input arrays 
=SUMPRODUCT(array1,array2,array3,…) 

=SUMPRODUCT((B3:B12="Australia")*(D3:F12)) 

The first expression in SUMPRODUCT is the criteria, we are checking if cells B3 to B12 contain the 
country “Australia”.  The result is an array of TRUE and FALSE values 
{FALSE;FALSE;TRUE;TRUE;TRUE;TRUE;FALSE;FALSE;FALSE;FALSE} 

This is multiplied by the values in the range D3:F12, where TRUE represents 1 and FALSE represents 
0. The result inside the SUMPRODUCT function looks like this: 
SUMRPRODUCT 
 
 ({0,0,0; 0,0,0; 150,25.95,95; 21.55,20.55,25.95; 19.95,25.95,50.95; 490, 
120,150; 0,0,0; 0,0,0; 0,0,0; 0,0,0;}) 
 

1. In cell J2 type the text Australia 
2. In cell K2 type the formula =SUMPRODUCT((B3:B12="Australia")*(D3:F12)) 
3. In cell J3 type the text Japan 
4. In cell K3 type the formula =SUMPRODUCT((B3:B12="Japan")*(D3:F12)) 
5. In cell J4 type the text Canada 
6. In cell K4 type the formula =SUMPRODUCT((B3:B12="Australia")*(D3:F12)) 
7. Now in cell J5 and K5, work out the last country that you need to add and the formula.
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Moving cells – drag and drop 
We are going to move our country totals down one row to allow for a heading 

1. Highlight cells from K5 to K5 

2. When the pointer becomes a move pointer  , drag the cell or range of cells to the J3 
location. 

3. In cell J3 type the heading Country 
4. In cell K3 type in the heading Total 
5. Make the headings Bold 

 
 

 

Conditional Formatting - Color Scales 
Color Scales in Excel makes it easy to visualize values in a range of cells. The shade of the color 
represents the cell value.  

1. Select cells K3 to K6 

2. Select Home > Styles group > Conditional Formatting > Color Scales > click Green - Yellow - 

Red Color Scale 

  

We can see the 3-color scale highlights the lowest value in 

red, the medium value in yellow and the highest value in 

green. 

 

 

 
 
 
TIPS and TRICKS 

Move cells by using Cut and Paste 
Select a cell or a cell range. 

Select Home > Cut  or press Ctrl + X. 
Select a cell where you want to move the data. 

Select Home > Paste  or press Ctrl + V. 

 

 
 
 
TIPS and TRICKS 

 
Previous Excel versions do not support this Conditional Formatting feature. 
Color scales are not displayed when you open the file with a 
previous Excel version in the compatibility mode. 
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Calculating percentages 
As with any formula in Excel, you need to start by typing an equal sign (=) in the cell where you want 
your result, followed by the rest of the formula. The basic formula for calculating a percentage is 
=part/total. 
 

1. In cell L2 type in the heading, % of Total 
2. Add Bold to your heading 
3. In cell K7 type in the formula = SUM(K3:K6) 
4. In cell L3 type in the formula =K3/K7 
5. Press the Enter key 
6. Select cell L3 and right mouse click to select Format Cells 

 
7. In the Format Cells window under the Number tab, select Percentage in Category and 

change the Decimal places to 0 

 
 

8. Click OK 
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Absolute Cell Reference in formula 
When you want to copy a formula, but need to consistently refer to a particular cell, you will need to 
use absolute cell reference. An absolute cell reference is a cell address that contains a dollar sign($) 
in the row or column coordinate (or both). A formula will be relative reference until you change it to 
absolute 

1. In cell L3 change the formula to read  =K3/$K$7 (This can also be done by highlighting K7 in 
the formula and selecting the F4 button. 

 
 

2. Select Enter 
3. Select cell L4 again, and this time the formula down by moving to the lower right hand 

corner of the cell, until a bold plus sign appears. Hold the left mouse click down and drag to 
L6  
 

 
 

Conditional Formatting – Top 10%  
1. Select the cells L3 to L6 
2. Select Home > Conditional Formatting > Top/Bottom Rules > Top 10% 

 
3. Use the drop down menu to change the color to Green Fill with Dark Green Text 

 
4. Click OK 
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Conditional Formatting – Icons 
 

1. Highlight cells L3 to L6 
2.  Select Home > Conditional Formatting > Icon Sets > Indicators, then select the Green, 

Yellow and Red Flags 
 

 
 

3. Select Home > Conditional Formatting > Manage Rules 
4. Have a look at the rule for the flags that you just created and have a play with changing the 

figures 

 

 

Apply conditional formatting based on text in a cell 
1. Select cells C3:C12 
2. Select HOME > Conditional Formatting > Highlight Cells Rules > Text that Contains.  
3. In the Text that Contains box, on the left, enter the text Clothing  
4. Select Red Text from the color drop down menu 
5. Select OK 
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Tables 
An Excel table is a great way to manage database information in a familiar spreadsheet format. 
There are many benefits of working with tables in Excel to manage data. 

• Tables automatically update when you enter data in a new row or column 

• Excel forms make data entry easy 

• You can add new rows by pressing Tab 

• Column headings are always visible 

• Data analysis benefits 

• Formulas stay consistent across all of your data 

• Graphs will automatically update to include all of your data 

Creating a table 
It is quick and easy to create a table 

1. Select the 7. Tables worksheet 

2. Place your cursor anywhere in the data 

3. Press Control + T 

4. Tick the box for My Table has headers 

  

5. Click OK 

 

 

 

  

 

 
 
 
TIPS and TRICKS 

 
 You can create a table by selecting the Insert tab, then the Tables group, 
then Table 
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Name your table 
Excel automatically names your table, such as table1, table2 etc.  The table name will display in the 
Name Box, making it easier to navigate.  

1. Select Table Design > Properties > Table Name, type in Student  

 

Navigate to a table 
Tables will appear in the name box dropdown menu, and you can automatically navigate to the tab 

on the workbook 

1. Select the Name Box drop down menu and select Student. Notice that you will have all 

the other tables from your workbook in this drop down menu. 

 

2. From the name box select MYOB, this will take you to a different spreadsheet that 

contains that table 

 

3. Select the Student table from the Name Box 
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Adding columns to tables 
 

1. Make sure you are on 7. Tables spreadsheet 
2. Select cell F1 
3. Right mouse click 
4. Select Insert 
5. Select Tables columns to the left 
6. Rename the table column Geography 

 

Applying Table Styles 
When you convert your range of data into an Excel table, by default the Excel shades every other 
row in the table making them easy to read.  
 
You can turn on/off the banded-row option from Table Style Options  
 

1. Select any cell B4 in the table 

2. Select the Table Design tab 

3. Under Table Styles, select the White Table Style Medium 4, which is grey in color 

 

         
4. Select Table Design > Table Style Options > select the checkbox for First Column 
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Adding data to a Table using form 
1. Go to the File menu and select Options 

2. Select Customise Ribbon 

3. Choose command from : All Commands 

4. Select Form and click the Add button, then click OK 

 

5. Select the form button  located on the quick access toolbar 

6. Click the New button 

7. Add in the new student details as the picture below 

 
8. Click New 

9. Open the form again and this time use the Find Next button to update the following student 

details 

Student name Geography 

John Henry A 

Sally Kim B 

Kylie Tyler C 

Peter Clark B 

Sue Hope A 

Kenny Kyle D 

New: Which will add new records to the database. 
Delete: Delete the specific records of the employee. 
Restore: Restore the old record. 
Find Next: Finds the next record. 
Find Previous: Find the Previous record. 
Criteria: Displays the records based on the employee criteria. 
Close: This will close the form window. 
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Scroll Bar: Where we can scroll up and down to see the record fields. 

Adding a slicer to a table 
Slicers provide buttons that you can click to filter table data, or Pivot table data. 
In addition to quick filtering, slicers also indicate the current filtering state, which makes it easy to 
understand what exactly is shown in a filtered PivotTable. 
 
You can use a slicer to filter data in a table with ease. 
Note: In order to use a slicer, your data will need to be in a table. 

 

Use a slicer to filter data 
1. Open the 8. Slicers sheet 

2. Add a table to the data 

3. Name the table, Slicers 

4. Click anywhere in the table 

5. Select Insert > Filter> Slicer  

6. Select the checkbox for Department in the Insert Slicers dialog box

 
7. Select OK 

8. Use the Department slicer button, select Produce 

 

  
 

9. Use the Department slicer button, select Produce 
 

Clear Filter for Slicer 

1.  To clear a slicer's filters, select Clear Filter  in the slicer. 
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Selecting more than one filer 
1. Click the Department slicer button, select Bakery 
2. Hold down the Ctrl key and press Meat and Produce. The multi selection button is also 

available  

 

 Slicer Style 
Just like a table, the slicer allows you to change the format 
 

1. Select the Department slicer button 
2. Select Slicer tab 
3. Under Slicer Styles, select the Light Green, Slicer Style Light 6 

 

 
 
4. Under Buttons change the columns to 2 and the Height to 1cm 
5. Select Size to Height 3.2 cm and Width 5.08cm 

 

 
Extension: Create 2 more slicer buttons for Category and Total 
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Customise a Slicer Style 
1. Select the slicer button that you have created called Department 

2. Choose Slicer Tab 

3. Under the Slicer Styles drop down, Right Click on the Light Green, Slicer Style Light 6 and 

choose Duplicate 

4. In the Modify Slicer Style rename your customise slicer to Sales 

 

 
5. Select a Whole Slicer under the Slicer Element and click on the Format button 

6. Select the Fill tab, select dark grey and OK and OK again 

7. In Slicer Styles, select the slicer that you have just created. 

 

 

 

 

  

 

 
 
 
TIPS and TRICKS 

 
              Setting a default slicer style for this document 

Note that you can select the tickbox for Set as default slicer style for 
this document 



23 
 

Data Validation 
To ensure correct entry of data you can create Drop Down lists  

 

Limiting data entry options 
1. Open the 9. Data Validation sheet. We are only wanting the operating to be able to select 

from a range of Subjects, rather than typing them in 

2. Highlight cells C4 to C15 

3. Select Data > Data Tools > Data Validation 

4. In the Validation criteria, select List under Allow 

5. Under Source type Maths, English, Science. Make sure to put commas in between them 

6. Select OK 

 

 

7. Add the following subjects for the students using the drop down list 
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Creating a Graph 
Excel offers three varieties of graphs include; 

• Line Graphs 
• Column Graphs 
• Bar Graphs 

In Excel the x-axis along the bottom is called the horizontal axis and the y-axis that runs up and 

down is called the vertical axis 

• Each axis can either be a value axis or a category axis.  

• • A value axis represents numerical values. For example, a value axis can represent dollars, 

hours, duration, temperature, and so on.  The vertical axis on the right is a value axis.  

• • A category axis represents things like dates, people names, product names. The horizontal 

axis on the right has years so this is a category axis.  

 

1. Open the 10. Charts sheet 

2. Click anywhere in the data 

3. Select Insert > Charts > Recommended Charts 

4. Select the clustered column graph 

 

5. Select Ok 

6. In the Chart Styles, try changing the style of the chart  
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7. Under Chart Styles, use the drop down menu to select Change Colors and select the orange 

8. Select Change Chart Type, change the chart to Bar then select Ok 

Chart elements 
1. Select the plus on the right hand side of the chart, this will display the Chart Elements 

2. Select the checkbox for Axis Titles 

3. In the horizontal axis type the title AMOUNT OF RUBBISH and the vertical axis to be YEAR 

LEVEL 

4. Select Data Table to display the data in the graph 
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Pivot Tables 

A PivotTable is a powerful tool to calculate, summarize, and analyse data that lets you see 

comparisons, patterns and trends in your data. 
 
 

1. Open the 11. PivotTables sheet 

2. Click any cell inside the data set 

3. On the Insert tab, in the Tables group, click PivotTable. Excel automatically selects the data 

for you.   

 

 
 

4. The default location for a new pivot table is New Worksheet. If you wanted the pivot table 

in the same location as the data, then you would change it to be Existing Worksheet 

 

5. Click OK 

6. Rename the sheet – Sales Pivot 
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7. The PivotTable Fields pane appears, drag the following fields to the different areas 

o Items to the Rows area 

o Total to Values area 

 

 

 

Above you can see the pivot table created. From this table was can easily see that MYOB 
AccountEdge Basic has made the most sales 
 

8. If you Pivot Table Fields have disappeared, then select Analyse tab, Show group, then Field 
List 

9. Drag the following fields to the different areas, if any fields already have fields, then you can 
left click to delete, or drag them out of the area 

o Sales rep to the Rows area 

o Items to Columns area 

o Total to Values area 

 

 

From this data we can clearly see that Tyler has the highest sales total. However, Gill has the highest 
sales in MYOB Essentials.  From this data I can also see that Andrews only sells 2 products, which are 
MYOB AccountEdge Basic and MYOB Essentials. 
 
Question: Can you notice anything else? 
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10. Drag the following fields to the different areas, if any fields already have fields, then you can 
left click to delete, or drag them out of the area 

o Sales rep to the Rows area 

o Order date to Columns area 

o Total to Values area 

 

Notice that is will group the sales in the relevant years.  This time I can see that the data is showing 

that even though Tyler has the greatest sales, Gill is beating Tyler for sales in the 2019 year. 

11. Click anywhere in the pivot table, select Analyze, then in the Pivot Table group, change the 

pivot table name to Sales per rep 

 

12. Highlight all of the pivot table for sales by year and copy, and then move the cell G3 and 

select paste.  This will allow you to create 2 pivot tables on one sheet 

13. Drag the following fields to the different areas, if any fields already have fields, then you can 
left click to delete, or drag them out of the area 

o Region to the Rows area 

o Total to Values area 

 

This data display the total of sales by State 

14. Rename the pivot table to Sale per state 

 

 
 
 
TIPS and TRICKS 

 
 Do remove fields in the Pivot Table Fields, simply untick the box 
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Adding Slicers to a Pivot Table 
Adding Slicers is a great way to filter data in a pivot table 

1. Select any cell in the Sale per state pivot table 

2. Select Insert, then Filters Group, then Slicer 

3. Check the tickbox for Quarters and Years in the Insert Slicer window, then select OK 

 

4. Move your slicer buttons to the right of your pivot table 

5. Right mouse click on the Quarters button, select Slicer Settings, then check the tickbox for 

hide items with no data. 

6. Right mouse click on the Year button, select Slicer Settings, then check the tickbox for hide 

items with no data. 

7. Select both Quarters and Years, select Options and then choose the Slicer Styles that we 

created in the Beginner excel training.  If you didn’t do this lesson, just select another slicer 

style 

8. Resize the button, by dragging to make it just the perfect size 

 

9. Select Qtr1 for 2019, the below data will display 

 

 


